Requirements
Your current browser version
Unknown 0.0 - other
Browser
To place an order online, you need a HTML5/CSS3 compatible browser.
Legend
  • Works perfectly
  • Works, but may have minor visual imperfections
  • Cannot be used or will miss essential features
  • Not tested yet, please report your experience to info@pantheradental.com
Rating
Javascript
JavaScript is mandatory to use this website, if JavaScript is not enabled, you must activate it or ask your IT departement to allow you to use the JavaScript on this website.
Cookies
The web cookies must be enabled to allow authentification and language selection.
Video
The help videos uses the HTML 5 standard for displaying video. The video player and codec must be supported by the browser itself. Panthera provides support for Ogg Theora (.ogg), VP8 WebM (.webm) and H264 video formats. You may check the following link to see if your browser supports any of those: http://en.wikipedia.org/wiki/HTML5_video#Browser_support
Flash
This website does not use any flash content, you do not need to have this plugin installed to use our website.

Confirmation